Comparison and Difference between HSRP, VRRP and GLBP Protocols

In this article I covered comparison of various first hop redundancy protocols. HSRP, VRRP and GLBP are the main three first hop redundancy protocols. In order to take the right decision for your network you should know the basics regarding all three.

The following chart provides difference HSRP Vs VRRP Vs GLBP protocols.

                            Difference between HSRP, VRRP and GLBP Protocols

Protocol Features HSRP VRRP GLBP
Scope Cisco Proprietary IEEE standard Cisco proprietary
Standard RFC2281 RFC3768 none
OSI Layer Layer-3 Layer-3 Layer-2
Load Balancing No No Yes
Multicast Group IP address 224.0.0.2 in version 1224.0.0.102 in version 2 224.0.0.18 224.0.0.102
Transport Port Number UDP 1985 UDP 112 UDP 3222
Timers Hello – 3 sec Advertisement – 1 sec Hello – 3sec
Hold – 10 sec Master down time = 3*Advertisement Time + Skew TimeSkew Time = (256-            Priority)/256 Hold – 10sec
Election Active Router:1.Highest Priority2. Highest IP address (Tiebreaker) Master Router: (*)
1-Highest Priority
2-Highest IP (Tiebreaker)
Active Virtual Gateway:
1-Highest Priority
2-Highest IP (Tiebreaker)
Router Role -One Active Router, one Standby Router-one or more listening Routers - One Active Router- One or More Backup Routers - One AVG (Active Virtual Gateway)- up to 4 AVF Routers on the group (Active Virtual Forwarder) passing traffic.- up to 1024 virtual Routers (GLBP groups) per physical interface.
Preempt If Active Router(Highest Priority) is down and up again, Preempt should be configured to become a Active Router again  By default Preempt is ON in VRRP, If Active Router is down and up again, It will automatically become a Master Router If Active Router(Highest Priority) is down and up again, Preempt should be configured to become a Active Router again.
Group Virtual Mac Address 0000.0c07.acxx 0000.5e00.01xx 0007.b4xx.xxxx
IPv6 support Yes No Yes

 

Note: In VRRP group, Router which is configured group as a real IP will become a Active Router, IOS will manage to make the VRRP Router with the real IP, the master, by setting its priority to 255, knowing that the configurable range is [1-254].

Share/Bookmark

Filed Under: HSRP/VRRP/GLBP

Tags:

About the Author:

RSSComments (21)

Leave a Reply | Trackback URL

  1. Manthri says:

    Hi,
    I faced a question in an interview ,
    that is hsrp supports for how many routers?
    can anybody help me?
    It’s possible to use GLBP with one router and two switches?

    • admin says:

      Hi Manthri,

      Answers

      1. There is no specific limitation in HSRP Protocol, One Router is active, one Router is standby and remaining all become listening Routers.

      2. You can run GLBP between one Router and two Switches but Switches have L3 capability, I means those must be L3 switches.

  2. Jason says:

    Great post. It would be nice if you pointed out the preempting defaults along with your note on preempt support:

    HSRP – yes (does not preempt by default)
    VRRP – yes (preempts by default; can be disabled)
    GLBP – yes (AVG does not preempt by default – requires “glbp preempt”; AVF preemption uses weighting instead of priority and is enabled by default with a default “glbp forwarder preempt delay” of 30 seconds)

  3. Peterson says:

    Very nice explain about Gateway redundancy protocols HSRP, VRRP and GLBP, keep updated like this with new stuffs and thanks…

  4. Jodo says:

    For managing voice and signalling links between MSS and MGW HUAWEI with 2 GIABIT ETHERNET, 2 PE and 2 NE40 Router;
    Wich is the best protocol to use to minimise the link switchover, VRRP or GLBP protocol ?.

    • admin says:

      Hi Jodo,

      GLBP is a Cisco proprietary protocol, which is not supported by Huawei, VRRP is standard protocol rfc3768, so for a mixed environments, configure VRRP with BFD for faster failure detection, you can also tune VRRP timer accordingly.

      Note: the advanced VRRP timer design, namely skew timer, which gives the Backup router with the highest priority (lowest skew value) better chance to take over the master mode.

      Thanks!

  5. Tajender Singh says:

    We have 2 Router 1800 and 2 link of 2Mbps each from different ISP. Is it possible to do load sharing and load balancing using these routers.

    • admin says:

      Hi Tejendar,

      HSRP, VRRP and GLBP protocols are primarily designed for layer 3 gateway redundancy but GLBP having both options gateway redundancy & load sharing and load balancing.

      GLBP is a Cisco Proprietary protocol, If you have two Cisco Routers, You can do the load balancing and load sharing.

      You can do the load balancing and load sharing With HSRP and VRRP protocols also but not by default, it is possible with multiple groups only.

      Thanks!

      • admin says:

        You can do load balancing with all the protocols. For HSRP and VRRP, two groups (2 gateway ip addresses) are needed and half of the clients point to gateway 1 and the rest point to gateway 2 even they are belonging to the same VLAN.
        With GLBP, only one gateway is needed. Router with higher priority takes up all the ARP request from clients and reply with different virtual MAC address (using Round Robin by default) from the GLBP group
        HSRP and GLBP support interface tracking, if one of the wan interface having problems, the priority of the internal interface will get deducted and causing alternative interface takes care of the traffic
        VRRP can assign same ip address to the interface as the gateway address, so it saves one ip address but HSRP cannot

        HSRP Configuration

        Router1#
        int f0/0
        ip address 192.168.1.11 255.255.255.0
        standby 1 ip 192.168.1.1
        standby 1 priority 120
        standby 1 preempt
        standby 2 ip 192.168.1.2
        standby 2 preempt
        standby 1 track s1/1 30
        no shut
        Router2#
        int f0/0
        ip address 192.168.1.12 255.255.255.0
        standby 2 ip 192.168.1.2
        standby 2 priority 120
        standby 2 preempt
        standby 1 ip 192.168.1.1
        standby 1 preempt
        standby 2 track s1/2 30
        no shut

        GLBP Configuration

        Router1#
        int f0/0
        ip address 192.168.1.11 255.255.255.0
        glbp 1 ip 192.168.1.1
        glbp 1 priority 200
        glbp 1 preempt
        no shut
        Router2#
        int f0/0
        ip address 192.168.1.12 255.255.255.0
        glbp 1 ip 192.168.1.1
        no shut

  6. Ravi says:

    Nice work buddy! Key points covered on First Hop Redundancy protocol comparison (HSRP,VRRP,GLBP).

  7. HSRP Timers says:

    You can edit HSRP’s timers lower than VRRP and obviously if your devices don’t support VRRP.

  8. Tanvir says:

    VRRP, not being a cisco proprietary protocol, has any shortfall over HSRP and GLBP ???
    so among all three protocols, which is the best protocol and why ?

  9. Pradyumna says:

    For load balencing VRRP sends more hellos which means these packets are shooting every second and may congest a network with alot of users, but may be good for smaller networks. anything flowing through the network takes bandwidth. EIGRP pretty much takes care of the all the routing really well even if you make mistakes. Anyways so why use HSRP?

  10. Praveen says:

    There is a minor error where Traffic type for VRRP is mentioned in the article, it doesn’t use UDP 112 but IP Protocol number 112.

  11. David Lundgren says:

    If I setup HSRP between 2 routers with a virtual IP shared between them on say the LAN side, would I need to set this up on the WAN side also? This refers to an ISP I used to work for but still help every now and then. They have a multi-link frame relay connection provided/owned by Sprint w/2800 router, ge uplinks into 3640 fe0/0 port owned by ISP, fe0/1 uplinks into a static ospf network. Would HSRP need to be setup on both sides of the 3640?

  12. Jodo says:

    There are a few more differences between HSRP and VRRP… In VRRP the standby speaker doesn’t send out hellos, while they do in HSRP. Threw me for a loop the first time I ran into it (Nokia IPSO hardware). I’m not so sure it’s supported on all the hardware that HSRP is, either.

    Jodo

  13. Ashok says:

    Good Document…
    I found it very useful while implementing VRRP feature for router

  14. David Lundgren says:

    I suppose I didn’t look at the picture long enough. I was distracted by the NAT translation out to the left of the pix. Anyways I now see the virtual IP is on both sides of the routers.

  15. Muhammad says:

    Why not use GLBP? You sated that the client didn’t need load balancing.
    Anyway, it’s always better to let the standby gateway do some stuff instead of doing nothing (load balancing). The only case I go against load balancing is:
    1) the standby gateway is very unstable
    2) the standby gateway is very slow

  16. John says:

    Thanks for sharing on Gateway redundancy protocols HSRP, VRRP and GLBP. Very nice!

  17. Amr says:

    Why GLBP is layer 2 ???

Leave a Reply




If you want a picture to show with your comment, go get a Gravatar.