How to create a Tunnel interface and configure between Cisco Routers

Create and Configure a Tunnel Interface on Cisco Router 

You can create a Tunnel interface on Cisco Router and establish a Tunnel between two locations. Tunnel between two location Routers are useful for load sharing on WAN links or Resources. Below I will share the Tunnel configuration on Cisco Router at both ends to establish a tunnel.

Create a Tunnel Interface on Cisco Router

Cisco-Router(config)#interface tunnel ?
<0-2147483647>  Tunnel interface number
Cisco-Router(config)#interface tunnel

Tunnel Configuration at A end Cisco Router:

interface Tunnel100
description ***Tunnel to B location ***
ip address 172.111.1.9 255.255.255.252
keepalive 5 4
tunnel source 172.111.46.1
tunnel destination 172.111.46.104
!

interface Fastethernet 0/0
description *** Tunnel  Source Interface ***
ip address 172.111.46.1 255.255.255.0 secondary
ip address 10.6.0.2 255.255.0.0
ip accounting output-packets
ip pim dense-mode
ip route-cache flow
!

Tunnel Configuration at B end Cisco Router:

interface Tunnel104
description ***Tunnel to  A Location ****
ip address 172.111.1.10 255.255.255.252
keepalive 5 4
tunnel source 172.111.46.104
tunnel destination 172.111.46.1
!

interface FastEthernet0/1.500
description *** Tunnel  Source Interface ***
encapsulation dot1Q 500
ip address 172.111.46.104 255.255.255.0

Be ensuring the tunnel destination is reachable via global routing using static or dynamic routing protocols not routed via the tunnel interface. As the tunnel is up if the source address is up use keepalives if you want the tunnel to go down when the destination is not available.

Share/Bookmark

Filed Under: Cisco General

Tags:

About the Author:

RSSComments (0)

Trackback URL

Leave a Reply




If you want a picture to show with your comment, go get a Gravatar.